[WEB SECURITY] Error with installing beef php version?

Kylah krystal_klass.kyky at yahoo.com
Tue Jan 8 22:56:44 EST 2013


I am trying to install the PHP version of BEEF and I've pretty much done 
everything I was supposed to. So when I go to the beef installation page on my 
server which is localhost/beef I get this error: 

array("min_range"=>0, "max_range"=>65535)); return filter_var($port, 
FILTER_VALIDATE_INT, $int_options); } function valid_url($url) { if( 
preg_match("/\.\./", $url) ) return FALSE; if( ! preg_match("/^[a-zA-Z0-
9\._:\/]*$/", $url) ) return FALSE; return filter_var($url, FILTER_VALIDATE_URL, 
FILTER_FLAG_SCHEME_REQUIRED); } function valid_url_without_query($url) { 
if(filter_var($url, FILTER_FLAG_QUERY_REQUIRED)) return FALSE; return 
valid_url($url); } ?> 

Fatal error: Call to undefined function valid_url_without_query() in 
C:\xampp\htdocs\beef\index.php on line 40


They've basically shown me what was in index.php and where the error was but I 
have no idea how to fix the error. Anyone have any ideas?





More information about the websecurity mailing list